Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 01, 2025 - 02:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 28, 2025 - 19:30 UTC
Scheduled
Pexip Government Cloud will be performing a midweek upgrade to our backend systems this Wednesday, 30 APR 2025, at approximately 2000 hrs Eastern time. Pexip anticipates no impacts to active or scheduled calls. Please contact Pexip Support at support@pexgov.com if you have any questions or concerns.
Posted Apr 28, 2025 - 19:23 UTC
This scheduled maintenance affected: Cloud Video Interop for Microsoft Teams, Pexip Government Cloud Portal, Registration and Call Service, VMR service, WebEx for Government Interconnect, and Zoom for Government Interconnect.