Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 16, 2026 - 23:00 UTC
Scheduled
Pexip Government Cloud will perform a system maintenance on 16 May 1026 beginning after 23:00 UTC (19:00 EDT / 18:00 CDT) and extending for 8 hours. This upgrade may intermittently impact calls through the PGC SIP service gateway. In the unlikely event that customers experience unanticipated call errors, please contact support@pexgov.com for further information.
Posted May 13, 2026 - 20:43 UTC
This scheduled maintenance affected: Cloud Video Interop for Microsoft Teams, WebEx for Government Interconnect, and Zoom for Government Interconnect.