Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 02, 2025 - 19:00 UTC
Scheduled
Pexip Government Cloud will perform a system upgrade on 2 August 2025 at approximately 1900 UTC (1400 EST / 1300 CST). This upgrade may intermittently impact CVI calls through the PGC SIP service gateway. In the unlikely event that customers experience unanticipated call errors, please contact support@pexgov.com for further information.
Posted Jul 31, 2025 - 00:45 UTC
This scheduled maintenance affected: Cloud Video Interop for Microsoft Teams, Registration and Call Service, VMR service, WebEx for Government Interconnect, and Zoom for Government Interconnect.