PGC has identified a cause for the affected calls, and implemented controlling mitigations. This page will be updated with further information as available.
Posted Jul 31, 2025 - 20:30 UTC
Investigating
We are investigating issues with inbound calling impacting some customers.
Posted Jul 31, 2025 - 17:32 UTC
This incident affected: Cloud Video Interop for Microsoft Teams and WebEx for Government Interconnect.